#StackBounty: #16.04 #php7 How to install php http_chunked_decode on Ubuntu 16.04?

Bounty: 50

I have tried same as I did on Ubuntu 14.04.:

apt-get install -y libpcre3-dev
apt-get install -y libcurl4-gnutls-dev
printf "n" | pecl install pecl_http-3.1.0

# did not install raphf and propro because they come with pecl_http

echo "extension=http.so" > /etc/php/7.0/mods-available/http.ini
ln -s /etc/php/7.0/mods-available/http.ini /etc/php/7.0/cli/conf.d/20-http.ini
ln -s /etc/php/7.0/mods-available/http.ini /etc/php/7.0/fpm/conf.d/20-http.ini
chmod 644 /etc/php/7.0/mods-available/http.ini

echo "extension=raphf.so" > /etc/php/7.0/mods-available/raphf.ini
ln -s /etc/php/7.0/mods-available/raphf.ini /etc/php/7.0/cli/conf.d/20-raphf.ini
ln -s /etc/php/7.0/mods-available/raphf.ini /etc/php/7.0/fpm/conf.d/20-raphf.ini
chmod 644 /etc/php/7.0/mods-available/raphf.ini

echo "extension=propro.so" > /etc/php/7.0/mods-available/propro.ini
ln -s /etc/php/7.0/mods-available/propro.ini /etc/php/7.0/cli/conf.d/20-propro.ini
ln -s /etc/php/7.0/mods-available/propro.ini /etc/php/7.0/fpm/conf.d/20-propro.ini
chmod 644 /etc/php/7.0/mods-available/propro.ini

I’m getting error:

PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php/20151012/http.so' - /usr/lib/php/20151012/http.so: cannot open shared object file: No such file or directory in Unknown on line 0

I have tried to find newer solution for installing http_chunked_decode on Ubuntu 16.04 but without success.

Thank you for help

UPDATE 1:
Also had to install:

apt-get install -y libcurl4-openssl-dev

Now I’m not getting anymore this error but function http_chunked_decode is still not working


Get this bounty!!!

Leave a Reply