#StackBounty: #postgresql #pg-dump #postgresql-10 Postgres pg_dump version mismatch… even though versions are the same

Bounty: 50

I’m trying to dump a Postgres db from Amazon RDS, which I recently updated to 10.1. To do so, I download pg_dump 10.1 from enterprisedb.com (http://get.enterprisedb.com/postgresql/postgresql-10.1-1-linux-x64-binaries.tar.gz) but when I try to use it, I get the following error:

pg_dump: server version: 10.1; pg_dump version: 10.1
pg_dump: aborting because of server version mismatch

This worked fine before, when RDS had version 9.6 and I used pg_dump 9.6 (downloaded from the same location).

I tried newer versions of pg_dump (10.2 and 10.3) but get the same error (which makes sense, because those newer versions actually don’t match the RDS version).

I also checked that no other pg_dump is installed on my server (Ubuntu 15.04 – I know I should update… waiting for 18.04), found one and deleted it, but get the same error.

What could be the problem here?


Get this bounty!!!

Leave a Reply