#StackBounty: #auctex AUCTeX error "Symbol’s function definition is void: texmathp"

Bounty: 100

From time to time I am having trouble using auctex properly. That means, after typing-in C-c C-f C-e I receive the following error message:

Symbol’s function definition is void: texmathp

Sometimes I am also unable to type in a minus symbol -, same error message.

I have installed auctex-12.1.1 via elpa (on a Windows machine, for more information see below).

I used to have something like

(require 'tex-site)
(require 'tex-mik)

in my init.el (see below).

The strange thing is, everything works without (require 'tex-mik) but then I am unable to use C-c C-f C-e (includes an emph{}) or C-c C-e, which I really depend on.

Any ideas what is going on?

My emacs version

In GNU Emacs 25.3.1 (x86_64-w64-mingw32)
 of 2017-09-12 built on KAEL
Windowing system distributor 'Microsoft Corp.', version 6.1.7601
Configured using:
 'configure --prefix=/tmp/emacs --without-imagemagick --without-dbus
 --with-modules 'CFLAGS=-O2 -g0''

My init.el (hopefully a MWE)

(require 'package)

(setq package-archives '(("gnu" . "http://elpa.gnu.org/packages/")
                         ("marmalade" . "http://marmalade-repo.org/packages/")
                         ("melpa" . "http://melpa.org/packages/")
             ("org" . "http://orgmode.org/elpa/")
             ("elpy" . "https://jorgenschaefer.github.io/packages/")
             ))

(setq package-check-signature nil)



(add-to-list 'load-path "~/.emacs.d/site-lisp/")  

(let ((default-directory "~/.emacs.d/site-lisp/"))
  (normal-top-level-add-subdirs-to-load-path))   

(package-initialize)

(require 'tex-site)
(require 'tex-mik)


Get this bounty!!!

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.