#StackBounty: #package-management #mingw #msys2 MSYS2 and "At least one valid and enabled repository required for this action to s…

Bounty: 50

I have separate MSYS2 32-bit and 64-bit installed on a Windows 8.1 test machine. MSYS2 was acquired from the MinGW-64 download page. Each installation has developer tools installed like GCC, Git, GDB, Make, etc.

I’m having trouble updating MSYS2. When I attempt to update components I receive “At least one valid and enabled repository required for this action to succeed”:

enter image description here

Settings | Network is set to No proxy. Settings | Repositories has the default repositories:

enter image description here

The problem occurs with both MSYS2 32-bit and MSYS2 64-bit. It also occurs with when running maintenancetool.exe as an administrator and as a regular user.

As far as I know, nothing has changed since the time I installed MSYS or the various developer packages. The repositories are the same as they were.

Searching is not turning up expected results. I expected lots of hits with lots of suggestions but there’s 5 results (which seems very odd).

Why am I encountering the error and how do I fix it?


Get this bounty!!!

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.