#StackBounty: #audio #usb-audio #microphone #arecord Constant beep when recording sound

Bounty: 50

I am using an external sound card with my Raspberry Pi 3 Model B+. I have already disabled the default bcm2835 sound card. I have checked that the my external sound card is active. I have turned up mic and capture volume using alsamixer. When I try to record sound using arecord, the sound output file has a constant beeping sound and no other sound is picked up. I tried playing music to see if the mic captures music sound in the background and it doesn’t. I tried only speaking to the mic and keeping it close while talking and it didn’t work. I am not sure what’s the issue here.

Any suggestions will be highly appreciated. Thanks

EDIT 1

I have tried a new sound card but still same problem. To add better context, I am adding some the details of the card and how I am trying to record:

arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC295 Analog [ALC295 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Device [USB PnP Sound Device], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Here’s how I am trying to record:

arecord -r 44100 -D hw:1,0 -f S16_LE -t wav -v testR1.wav

I have also tried pulseaudio:

parecord --channels=1 -d alsa_input.usb-C-Media_Electronics_Inc._USB_PnP_Sound_Device-00.analog-mono filename.wav**strong text**

Same result unfortunately!


Get this bounty!!!

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.