#StackBounty: #drivers #wireless #kernel #compiling #dkms Can't install rtl8192eu-linux-driver on UBUNTU 18.10

Bounty: 50

I am using UBUNTU 18.10 and I had problem with TL-WN822n v5 driver in UBUNTU and Kali (4.19.0-kali5-amd64)

The problem is driver=rtl8xxxu so I found a driver in this page :
https://github.com/Mange/rtl8192eu-linux-driver

and installed the driver on Kali and it worked perfectly fine but when I wanted to install it on my ubuntu, after I ran the udo dkms install rtl8192eu/1.0; I got this error :

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area...
'make' all KVER=4.18.0-25-generic...(bad exit status: 2)
ERROR (dkms apport): binary package for rtl8192eu: 1.0 not found
Error! Bad return status for module build on kernel: 4.18.0-25-generic (x86_64)
Consult /var/lib/dkms/rtl8192eu/1.0/build/make.log for more information.

and This is my Log file (/var/lib/dkms/rtl8192eu/1.0/build/make.log) :

DKMS make.log for rtl8192eu-1.0 for kernel 4.18.0-25-generic (x86_64)
Sun Jul  7 13:35:02 +0430 2019
make ARCH=arm64 CROSS_COMPILE= -C /lib/modules/4.18.0-25-generic/build 
M=/var/lib/dkms/rtl8192eu/1.0/build  modules
make[1]: Entering directory '/usr/src/linux-headers-4.18.0-25-generic'
  CC [M]  /var/lib/dkms/rtl8192eu/1.0/build/core/rtw_cmd.o
gcc: error: unrecognized command line option ‘-mlittle-endian’; did you mean ‘-fconvert=little-endian’?
make[2]: *** [scripts/Makefile.build:325:/var/lib/dkms/rtl8192eu/1.0/build/core/rtw_cmd.o] Error 1
make[1]: *** [Makefile:1534:_module_/var/lib/dkms/rtl8192eu/1.0/build] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-4.18.0-25-generic'
make: *** [Makefile:1710: modules] Error 2

What’s the problem ??


Get this bounty!!!

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.