#StackBounty: #memory #cpu #motherboard #uefi #ddr UEFI configuration for DDR4 memory on ASRock X99 Extreme3

Bounty: 200

I once over-estimated my knowledge of hardware (especially combination of motherboard and memory) and bought 4x 16GB GeIL EVO Potenza DDR4-3000 DIMM CL16 for an ASRock X99 Extreme3. I tried to configure it myself, but I never got the forth memory bar to be recognized and the Ubuntu system thus had only 12 of 16 GB available memory.

Then, I brought the PC to a professional for some repairs and asked that the configuration ought to be checked. He indeed succeeded to configure the UEFI to make all 4 bars work with a maximum frequence of approx. half of the 3000MHz available (I think 1600).

Now, I left the PC turned off for some months and the UEFI settings got erased. I forgot that that happens… Now, I’d like to find these settings again to save myself the way to the store and maybe learn something about memory configuration.

The product details from the sellers homepage (translated):

Model name:     EVO Potenza
Capacity:   16GB
# of modules:   4x
Capacity of each module:    4096MB
Type of memory:     DDR4-3000
JEDEC Norm:     PC4-24000U
Memory type:    unbuffered
Norm:   DIMM
Memory interface:   DDR4
Max. Frequency:     3000MHz
Voltage:    1.35V
Connection:     288-pin
Latency (CL):   CL16
RAS to CAS Delay (tRCD):    16
Ras Precharge Time (tRP):   16
Row Active Time (tRAS):     36
Features:   XMP 2.0 Support

I have the following options available in the UEFI (version 3.70):

BCLK Frequency
DRAM Voltage
DRAM Reference Clock
DRAM Frequency (Auto | DDR4-800 | DDR4-1066 | DDR4-1333 | DDR4-1600)

Primary Timing Options:
CAS# Latency (tCL)
RAS# to CAS# Delay (TRCD)
Raw Percentage Time (tRP)
RAS# Active Time (tRAS)
Command Rate (CR)

Secondary Timing Options:
Write Recovery Time (tWR)
Refresh Cycle Time (tRFC)
RAS to RAS Delay (tRRD)
RAS to RAS Delay (tRRD_L)
Write to Read Delay (tWTR)
Write to Read Delay (tWTR_L)
Read to Percentage (tRTP)
Four Activate Window (tFAW)
CAS Write Latency (tCWL)

Third Timing Options and Advanced Settings
[I can list them if that if that helps]

I already tried to set all options available from the product details which still causes only 3 of 4 bars to be recognized.

The CPU is Intel(R) XEON(R) CPU E5-2603 v3 @ 1.60GHz. The OS is now Ubuntu 18.04 (in case that matters, the memory is already not recognized in the UEFI).

16GB of RAM installed, ~12GB useable is marked as duplicate of question regarding Windows which has never been involved in my system or an erroneous connection of the memory or CPU socket which I believe is unlikely since the problem is identical to the situation before the first fix which needs to be found again (unfortunately and because of my bad).


Get this bounty!!!

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.