#StackBounty: #magento2 #error #composer Problem when installing module with composer

Bounty: 50

When I run the following command on my Magento 2.3.3 store I get an error:

composer require fooman/pdfcustomiser-m2

This is the error I’m getting:

    - magento/framework 100.1.15 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/framework 100.1.14 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/framework 100.1.13 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/framework 100.1.12 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/framework 100.1.11 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/framework 100.1.10 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/framework 100.1.9 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/framework 100.1.8 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/framework 100.1.7 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/framework 100.1.6 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/framework 100.1.5 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/framework 100.1.4 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/framework 100.1.3 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/framework 100.1.2 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/framework 100.1.1 requires php ~5.6.0|7.0.2|~7.0.6 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/framework 100.1.0 requires php ~5.6.0|7.0.2|~7.0.6 -> your PHP version (7.1.16) does not satisfy that requirement.
    - Conclusion: don't install magento/framework 101.0.0
    - magento/framework 101.0.1 requires composer/composer 1.4.1 -> satisfiable by composer/composer[1.4.1].
    - magento/framework 101.0.2 requires composer/composer 1.4.1 -> satisfiable by composer/composer[1.4.1].
    - magento/framework 101.0.3 requires composer/composer 1.4.1 -> satisfiable by composer/composer[1.4.1].
    - magento/framework 101.0.4 requires composer/composer 1.4.1 -> satisfiable by composer/composer[1.4.1].
    - Conclusion: don't install composer/composer 1.4.1|install magento/framework 101.0.0
    - Installation request for fooman/pdfcustomiser-m2 ^8.2 -> satisfiable by fooman/pdfcustomiser-m2[8.2.2].
    - Conclusion: don't install magento/framework 102.0.3|install magento/framework 101.0.0|install magento/framework 101.0.1|install magento/framework 101.0.2|install magento/framework 101.0.3|install magento/framework 101.0.4
    - Conclusion: remove magento/framework 102.0.3|install magento/framework 101.0.0|install magento/framework 101.0.1|install magento/framework 101.0.2|install magento/framework 101.0.3|install magento/framework 101.0.4
    - fooman/pdfcustomiser-m2 8.2.2 requires magento/framework 100.1.0 - 100.1.18 | 101.0.0 - 101.0.9 | 102.0.0 - 102.0.2 -> satisfiable by magento/framework[100.1.0, 100.1.1, 100.1.2, 100.1.3, 100.1.4, 100.1.5, 100.1.6, 100.1.7, 100.1.8, 100.1.9, 101.0.0, 101.0.1, 100.1.10, 100.1.11, 101.0.2, 100.1.12, 101.0.3, 100.1.13, 101.0.4, 101.0.5, 100.1.14, 100.1.15, 101.0.6, 100.1.16, 101.0.7, 102.0.0, 100.1.17, 102.0.1, 101.0.8, 102.0.2, 100.1.18, 101.0.9].
    - Can only install one of: magento/framework[102.0.3, 101.0.5].
    - Can only install one of: magento/framework[102.0.3, 101.0.6].
    - Can only install one of: magento/framework[102.0.3, 100.1.16].
    - Can only install one of: magento/framework[102.0.3, 101.0.7].
    - Can only install one of: magento/framework[102.0.3, 102.0.0].
    - Can only install one of: magento/framework[102.0.3, 100.1.17].
    - Can only install one of: magento/framework[102.0.3, 102.0.1].
    - Can only install one of: magento/framework[102.0.3, 101.0.8].
    - Can only install one of: magento/framework[102.0.3, 102.0.2].
    - Can only install one of: magento/framework[102.0.3, 100.1.18].
    - Can only install one of: magento/framework[102.0.3, 101.0.9].
    - Installation request for magento/framework (locked at 102.0.3) -> satisfiable by magento/framework[102.0.3].

Does anyone know how to solve this?

I have modified my composer.lock file so it doesnt say anyting with magento/framwork below version 102.*

EDIT:
When I enter the following command:

composer require fooman/pdfcustomiser-m2 --ignore-platform-reqs

I get the following error:

    - Conclusion: don't install magento/framework 101.0.0
    - magento/framework 101.0.1 requires colinmollenhour/php-redis-session-abstract 1.3.4 -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.3.4].
    - magento/framework 101.0.2 requires colinmollenhour/php-redis-session-abstract 1.3.4 -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.3.4].
    - magento/framework 101.0.3 requires colinmollenhour/php-redis-session-abstract 1.3.4 -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.3.4].
    - magento/framework 101.0.4 requires colinmollenhour/php-redis-session-abstract 1.3.4 -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.3.4].
    - magento/framework 101.0.5 requires colinmollenhour/php-redis-session-abstract 1.3.4 -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.3.4].
    - magento/framework 101.0.6 requires colinmollenhour/php-redis-session-abstract 1.3.4 -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.3.4].
    - magento/framework 101.0.7 requires colinmollenhour/php-redis-session-abstract 1.3.4 -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.3.4].
    - magento/framework 101.0.8 requires colinmollenhour/php-redis-session-abstract 1.3.4 -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.3.4].
    - magento/framework 101.0.9 requires colinmollenhour/php-redis-session-abstract 1.3.4 -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.3.4].
    - Conclusion: don't install colinmollenhour/php-redis-session-abstract v1.3.4|install magento/framework 101.0.0
    - Installation request for fooman/pdfcustomiser-m2 ^8.2 -> satisfiable by fooman/pdfcustomiser-m2[8.2.2].
    - Conclusion: don't install magento/framework 102.0.3|install magento/framework 101.0.0|install magento/framework 101.0.1|install magento/framework 101.0.2|install magento/framework 101.0.3|install magento/framework 101.0.4|install magento/framework 101.0.5|install magento/framework 101.0.6|install magento/framework 101.0.7|install magento/framework 101.0.8|install magento/framework 101.0.9
    - Conclusion: remove magento/framework 102.0.3|install magento/framework 101.0.0|install magento/framework 101.0.1|install magento/framework 101.0.2|install magento/framework 101.0.3|install magento/framework 101.0.4|install magento/framework 101.0.5|install magento/framework 101.0.6|install magento/framework 101.0.7|install magento/framework 101.0.8|install magento/framework 101.0.9
    - fooman/pdfcustomiser-m2 8.2.2 requires magento/framework 100.1.0 - 100.1.18 | 101.0.0 - 101.0.9 | 102.0.0 - 102.0.2 -> satisfiable by magento/framework[100.1.0, 100.1.1, 100.1.2, 100.1.3, 100.1.4, 100.1.5, 100.1.6, 100.1.7, 100.1.8, 100.1.9, 101.0.0, 101.0.1, 100.1.10, 100.1.11, 101.0.2, 100.1.12, 101.0.3, 100.1.13, 101.0.4, 101.0.5, 100.1.14, 100.1.15, 101.0.6, 100.1.16, 101.0.7, 102.0.0, 100.1.17, 102.0.1, 101.0.8, 102.0.2, 100.1.18, 101.0.9].
    - Can only install one of: magento/framework[102.0.3, 100.1.0].
    - Can only install one of: magento/framework[102.0.3, 100.1.1].
    - Can only install one of: magento/framework[102.0.3, 100.1.2].
    - Can only install one of: magento/framework[102.0.3, 100.1.3].
    - Can only install one of: magento/framework[102.0.3, 100.1.4].
    - Can only install one of: magento/framework[102.0.3, 100.1.5].
    - Can only install one of: magento/framework[102.0.3, 100.1.6].
    - Can only install one of: magento/framework[102.0.3, 100.1.7].
    - Can only install one of: magento/framework[102.0.3, 100.1.8].
    - Can only install one of: magento/framework[102.0.3, 100.1.9].
    - Can only install one of: magento/framework[102.0.3, 100.1.10].
    - Can only install one of: magento/framework[102.0.3, 100.1.11].
    - Can only install one of: magento/framework[102.0.3, 100.1.12].
    - Can only install one of: magento/framework[102.0.3, 100.1.13].
    - Can only install one of: magento/framework[102.0.3, 100.1.14].
    - Can only install one of: magento/framework[102.0.3, 100.1.15].
    - Can only install one of: magento/framework[102.0.3, 100.1.16].
    - Can only install one of: magento/framework[102.0.3, 102.0.0].
    - Can only install one of: magento/framework[102.0.3, 100.1.17].
    - Can only install one of: magento/framework[102.0.3, 102.0.1].
    - Can only install one of: magento/framework[102.0.3, 102.0.2].
    - Can only install one of: magento/framework[102.0.3, 100.1.18].
    - Installation request for magento/framework (locked at 102.0.3) -> satisfiable by magento/framework[102.0.3].```


Get this bounty!!!

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.