#StackBounty: #linux #keyboard #linux-mint Keyboard driver malfunction on ThinkPad T470s running Linux Mint (possibly after installing …

Bounty: 200

Recently, my Lenovo ThinkPad T470s laptop started acting up: when booted to Linux Mint 19.3 (it has dual-boot option with stock Windows 10 as an alternative), the system acts like left Control key is constantly pressed. If I change key mapping in BIOS setting (ThinkPads have an option to "swap" Fn and Control key functions), Fn key is being detected as constantly pressed instead.

Why do I believe it is a programmatical error instead of hardware failure?

  • The behavior doesn’t reproduce when booted to Windows 10
  • The behavior doesn’t reproduce in Linux Mint 19.3 Live USB
  • If the keyboard is programmatically detached via xinput (see here: https://askubuntu.com/questions/160945/is-there-a-way-to-disable-a-laptops-internal-keyboard) and then reattached (i.e. xinput float X xinput reattach X Y), the problem stops occuring until the next reboot. In fact, it’s gone once xinput float is executed.
  • I’ve never noticed the problem when I’ve started Linux without lightdm (via inline editing grub config during boot)
  • evtest produces no output when no buttons are pressed on keyboard (on the other hand, I’ve tried physically "sticking" the right Control key with putting weight on top of it prior to launching evtest and there was output of KEY_RIGHTCTRL scan codes being detected), also producing no output when left Control key is pressed.

I still am not 100% sure that it is not a hardware issue, that’s why I’ve ordered a replacement from AliExpress – I’ll provide an update here when the replacement keyboard arrives and is installed. I’ve tried to remove keyboard physically – obviously the problem never occurs then (I use external keyboard to verify).

The major things I’ve done to my system before I’ve started noticing it was installing virtualbox-6.1 package from official PPA. Although running apt purge virtualbox-6.1 didn’t solve the issue at all.

Obviously, I can reinstall the OS and the problem would 99% be gone, but I wouldn’t like to do so, instead trying to understand what is going on.


Get this bounty!!!

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.