#StackBounty: #usb #android #usb-storage #lubuntu Lost USB access to my Samsung GS6 phone

Bounty: 50

All other devices on my Lubuntu 20.04LTS system hotplug fine, with a message asking if I want to open the device in my file manager. However, as of yesterday, I have lost this when I plug in my Android Samsung GS6 phones. Normally, I’m prompted to "Allow" the connection (on the phone) then if I select "Yes" it will open the file manager prompt. Now, all that happens (on two phones) is that the "charging" indicator comes on.

I have tried the following things and identified that this is an issue with the Lubuntu 20.04LTS system:

  1. Tried phone 1 with different cable (no dice).
  2. Tried phone 2 with same cable (no dice).
  3. Tried phone 2 with different cable (no dice).
  4. Plugged in USB flash drive (works fine).
  5. Plugged phones into Lubuntu 20.04LTS laptop (works fine).
  6. Turned off system (as opposed to reboot) and restarted (no dice).
  7. Tried dialing *#0808# and selecting (then reselecting) MTP – ADB
  8. Ran "lsusb" and can see the phone is recognized: "Bus 001 Device 017: ID 04e8:6860 Samsung Electronics Co., Ltd Galaxy series, misc. (MTP mode)"
  9. Here is the appropriate "dmesg" output:
[45269.216369] usb 1-11: new high-speed USB device number 18 using xhci_hcd
[45269.366168] usb 1-11: New USB device found, idVendor=04e8, idProduct=6860, bcdDevice= 4.00
[45269.366173] usb 1-11: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[45269.366177] usb 1-11: Product: SAMSUNG_Android
[45269.366180] usb 1-11: Manufacturer: SAMSUNG
[45269.366182] usb 1-11: SerialNumber: 04157df4a262a410

I have a feeling that either a recent update (the system has been updating frequently) OR my own fiddling while trying to get a USB connection to a DSLR. (Installed v4l2loopback, gphoto2, etc.) I would greatly appreciate any help in getting this working again.


Get this bounty!!!

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.