#StackBounty: #18.04 #lenovo #overheating #fan #temperature Lenovo Y540 overheating issue

Bounty: 50

I have recently increased the size of my Ubuntu /home directory and reinstalled both Windows and Ubuntu on my Lenovo Legion Y540 laptop. Installation went smooth, but after all of it I have noticed that my Laptop gets significant heat (palpable on keyboard) even when simple web browsing. I have installed lm-sensors to check for the temperature of my CPU and straight after booting Ubuntu, temperatures were as follows:

coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +66.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +66.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +64.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +66.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +63.0°C  (high = +100.0°C, crit = +100.0°C)
Core 4:        +63.0°C  (high = +100.0°C, crit = +100.0°C)
Core 5:        +62.0°C  (high = +100.0°C, crit = +100.0°C)

At the time of writing this post I have only a dozen or so Firefox tabs enabled and the temperature are as below:

coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +85.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +85.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +79.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +85.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +81.0°C  (high = +100.0°C, crit = +100.0°C)
Core 4:        +85.0°C  (high = +100.0°C, crit = +100.0°C)
Core 5:        +81.0°C  (high = +100.0°C, crit = +100.0°C)

Therefore, I am concerned to do any computing as those temperatures would certainly go even higher. I have this laptop for about 6 months and I didn’t observed this significant keyboard heat before. Any ideas what may be causing this issue and what should I change to prevent it?

I’ll be happy to provide any additional information.

@Edit: I worked on Windows for a couple of minutes. I don’t know how can I measure the CPU temperature on Windows, but palpably, the issue was absent there.

@Edit2: I switched to Intel GPU as advised by @heynnema, the current output of sensors is:

coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +84.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +76.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +75.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +85.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +76.0°C  (high = +100.0°C, crit = +100.0°C)
Core 4:        +80.0°C  (high = +100.0°C, crit = +100.0°C)
Core 5:        +77.0°C  (high = +100.0°C, crit = +100.0°C)

Where as the output of ps auxc | grep -i therm. is:

root       210  0.0  0.0      0     0 ?        I<   cze07   0:00 acpi_thermal_pm
root       884  0.0  0.0 188224  9644 ?        Ssl  cze07   0:00 thermald


Get this bounty!!!

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.