#StackBounty: #centos #networking #docker #bridge #plesk Connecting to docker bridged container on CentOS 7 gives: Connection reset by …

Bounty: 50

As the title says I have a docker image which runs fine on my development machine in docker using network bridged to an another port (-p 8080:5000). But as soon as I am deploying this on my server connections fail.

-> Ruling out not hosting the application on 0.0.0.0:5000 IP’s.

When using --network host the images do run fine.

I would like to use the Plesk docker extension. The only supported behaviour in here is using the docker bridge network.

This server is running

  • Plesk => docker extension
  • CentOS 7

I did have some issues with the firewall settings (There are 2 active firewalls: firewalld and the Plesk Firewall). But the issue persists when both are disabled.

-> Ruling out firewall zone trust issues.

The last answer which came up while searching is a collision in network interface IP ranges..? But I have a simple setup with a single interface eth0 (public IP), local loopback and docker0.

What could be wrong here? Any ideas how to troubleshoot this further? I am out after many hours spent researching this issue.

Thanks!

> docker ps

CONTAINER ID        IMAGE                        COMMAND                  CREATED             STATUS              PORTS                    NAMES
8c3d3f32b8ef        savahdevelopment/savah_api   "dotnet savah_api.dll"   11 minutes ago      Up 11 minutes       0.0.0.0:8888->5000/tcp   sharp_lamarr

b355e8fef0ec        savahdevelopment/savah_api   "dotnet savah_api.dll"   7 hours ago         Up 14 minutes                                savah_api_prod

e38e1b01b039        savahdevelopment/savah_api   "dotnet savah_api.dll"   7 hours ago         Up 14 minutes                                savah_api_dev

> curl http://something.hostbeter.nl:5000/admin/test
YUUUUUUUUUUUUUUP!!

> curl http://something.hostbeter.nl:5100/admin/test
YUUUUUUUUUUUUUUP!!

> curl http://something.hostbeter.nl:8888/admin/test
curl: (56) Recv failure: Connection reset by peer

Some extra info:

netstat -tulp tells me the working containers did bind to the IPv6 addresses only. But connecting externally with the IPv4 works fine? So it seems to be something network related?


Get this bounty!!!

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.