#StackBounty: #ubuntu #networking #iwlwifi WiFi suddenly stopped working on Ubuntu 18

Bounty: 100

My Situation is exactly equal to OP’s from this question (except for the exact hardware configuration; I can add some more details if needed), but the answer that fixed the issue there didn’t work for me. In particular, the output to sudo dmesg |grep iwl is practically the same, i.e.

[    3.252011] iwlwifi 0000:00:14.3: loaded firmware version 34.3125811985.0 op_mode iwlmvm
[    3.299337] iwlwifi 0000:00:14.3: Detected Intel(R) Dual Band Wireless AC 9560, REV=0x318
[    3.343796] iwlwifi 0000:00:14.3: Microcode SW error detected. Restarting 0x0.
[    3.343813] iwlwifi 0000:00:14.3: Not valid error log pointer 0x00000000 for Init uCode
[    3.343932] iwlwifi 0000:00:14.3: SecBoot CPU1 Status: 0x3, CPU2 Status: 0x2458
[    3.343933] iwlwifi 0000:00:14.3: Failed to start INIT ucode: -5
[    3.356889] iwlwifi 0000:00:14.3: Failed to run INIT ucode: -5

However, there, the issue was resolved by the combination

sudo rmmod iwlmvm && sudo modprobe iwlmvm

When I execute this, the output of sudo dmesg |grep iwl just adds a few lines indicating more that isn’t working:

[    3.252011] iwlwifi 0000:00:14.3: loaded firmware version 34.3125811985.0 op_mode iwlmvm
[    3.299337] iwlwifi 0000:00:14.3: Detected Intel(R) Dual Band Wireless AC 9560, REV=0x318
[    3.343796] iwlwifi 0000:00:14.3: Microcode SW error detected. Restarting 0x0.
[    3.343813] iwlwifi 0000:00:14.3: Not valid error log pointer 0x00000000 for Init uCode
[    3.343932] iwlwifi 0000:00:14.3: SecBoot CPU1 Status: 0x3, CPU2 Status: 0x2458
[    3.343933] iwlwifi 0000:00:14.3: Failed to start INIT ucode: -5
[    3.356889] iwlwifi 0000:00:14.3: Failed to run INIT ucode: -5
[  214.811314] iwlwifi 0000:00:14.3: Detected Intel(R) Dual Band Wireless AC 9560, REV=0x318
[  214.856704] iwlwifi 0000:00:14.3: Microcode SW error detected. Restarting 0x0.
[  214.856720] iwlwifi 0000:00:14.3: Not valid error log pointer 0x00000000 for Init uCode
[  214.856868] iwlwifi 0000:00:14.3: SecBoot CPU1 Status: 0x3, CPU2 Status: 0x2458
[  214.856877] iwlwifi 0000:00:14.3: Failed to start INIT ucode: -5
[  214.869585] iwlwifi 0000:00:14.3: Failed to run INIT ucode: -5

The output to iw list is also, still, nothing.

I also did (prior to following above linked answer)

sudo apt-get install --reinstall bcmwl-kernel-source

which also didn’t help and might have been a mistake.

Any further help is very much appreciated!


Get this bounty!!!

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.