#StackBounty: #display #multiple-monitors #gpu #nvidia-geforce GPU not working on certain monitors

Bounty: 100

Running on Windows 10 Home latest.
I have no idea what is going on but after a morning of troubleshooting I am at a loss.

My issue is as follows, I have a 2080ti, it has 3 DP and 1 HDMI input.
Up until this morning I had 1 4K 144hz DP Monitor (Main), 1 144hz DP Monitor (Satellite) and 1 60hz HDMI monitor (Satellite 2). The last DP port I use for my Valve Index when I am playing.
This morning the Main display would not work, I tried swapped cords around on diff ports, I did a fresh uninstalled and reinstall of the latest display driver. I used a HDMI(Mon) to DP(PC) cord on my DP Satellite monitor to see if it was the cord since I did not have an extra DP cord and it then let my main and satellite to work, the HDMI is no longer working now but I have my 2 main ones.
I then same dayed a new DP cord for my main monitor to see if it was the cord, but plugging it in immediately turns off my main display and my hdmi monitor comes back on, I am so baffled on what is happening.

Thanks in advance for any help, here is my sysinfo https://gist.github.com/ggoodwin/309bdee7af1f083d6b59477e9e4fafb0

I can actually get it to work in a very specific port configuration and if I unplug the HDMI from the 3rd satellite the main monitor stops working again, so I temporarily have a fix but I occasionally hook up my satellite monitor to a laptop and would like to still solve the root problem.


Get this bounty!!!

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.