#StackBounty: #kernel #keyboard #logitech Logitech external keyboard stopped working after Ubuntu 20.10 and also 21.04

Bounty: 50

I am really starting to find this annoying as I was hoping after an upgrade to Ubuntu 21.04 the problem would be gone but it’s still here.

Everything works except the logitech external usb keyboard.

uname -a
5.11.0-22-generic #23-Ubuntu SMP Thu Jun 17 00:34:23 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 009: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 007: ID 5986:211b Acer, Inc HD Webcam
Bus 001 Device 005: ID 06cb:009b Synaptics, Inc. 
Bus 001 Device 003: ID 8087:0aa7 Intel Corp. Wireless-AC 3168 Bluetooth
Bus 001 Device 010: ID 046d:c534 Logitech, Inc. Unifying Receiver
Bus 001 Device 008: ID 046d:0a29 Logitech, Inc. H600 [Wireless Headset]
Bus 001 Device 006: ID 0000:0538   USB OPTICAL MOUSE
Bus 001 Device 004: ID 2101:8501 ActionStar USB HID
Bus 001 Device 002: ID 2101:8500 ActionStar USB2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

So far kernel 5.8.0 does not work (Ubuntu 20.10) and kernel 5.11.0 (Ubuntu 21.04) also does not work. If I manually select kernel 4.15.0 the keyboard works again. I had a setup to always start with that kernel but I am looking for a better solution to use the latest kernel. I also don’t want to reinstall the system if possible. I tried logging in with Ubuntu Xorg but that does not work
I also tried going to /etc/modprobe.d and see if anything was blacklisted that did not make sense. I did find blacklist usbkbd so I disabled that but it did not help.

Any ideas?

Update: it’s an msi PS42 laptop


Get this bounty!!!

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.