#StackBounty: #magento2 #upgrade #composer #phpunit #magento2.4.3 Magento 2.4.3 and Composer error messages for allure phpunit and rams…

Bounty: 50

I’m getting some error messages from composer, when I try to upgrade from Magento 2.4.2 to Magento 2.4.3, and these are:

- Root composer.json requires magento/product-community-edition 2.4.3 -> satisfiable by magento/product-community-edition[2.4.3].
- allure-framework/allure-codeception[1.4.3, ..., 1.4.4] require allure-framework/allure-php-api ~1.1.8 -> satisfiable by allure-framework/allure-php-api[1.1.8].
- allure-framework/allure-codeception 1.4.2 requires allure-framework/allure-php-api ~1.1.7 -> satisfiable by allure-framework/allure-php-api[1.1.7, 1.1.8].
- allure-framework/allure-php-api[1.1.6, ..., 1.1.8] require ramsey/uuid ^3.0 -> satisfiable by ramsey/uuid[3.0.0, ..., 3.9.4].
- allure-framework/allure-php-api 1.1.5 requires ramsey/uuid ^3.0.0 -> satisfiable by ramsey/uuid[3.0.0, ..., 3.9.4].
- Only one of these can be installed: rhumsaa/uuid[2.7.0, ..., 2.8.2], ramsey/uuid[3.0.0, ..., 3.9.4, 4.0.0, ..., 4.2.1]. ramsey/uuid replaces rhumsaa/uuid and thus cannot coexist with it.
- magento/product-community-edition 2.4.3 requires ramsey/uuid ~4.1.0 -> satisfiable by ramsey/uuid[4.1.0, 4.1.1].
- Conclusion: don't install ramsey/uuid[4.1.1] | install one of magento/magento2-functional-testing-framework[3.6.0, 3.6.1] (conflict analysis result)
- Conclusion: don't install magento/magento2-functional-testing-framework 3.6.0 (conflict analysis result)
- Conclusion: don't install magento/magento2-functional-testing-framework 3.6.1 (conflict analysis result)
- Root composer.json requires magento/magento2-functional-testing-framework ^3.0 -> satisfiable by magento/magento2-functional-testing-framework[3.0.0, ..., 3.6.1].
- Root composer.json requires allure-framework/allure-phpunit ~1.2.0 -> satisfiable by allure-framework/allure-phpunit[1.2.0, ..., 1.2.4].
- You can only install one version of a package, so only one of these can be installed: allure-framework/allure-php-api[1.1.0, ..., 1.3.1].
- allure-framework/allure-codeception 1.4.5 requires allure-framework/allure-php-api ~1.2.1 -> satisfiable by allure-framework/allure-php-api[1.2.1].
- Conclusion: install one of magento/magento2-functional-testing-framework[3.6.0, 3.6.1], allure-framework/allure-codeception[1.4.2, 1.4.3, 1.4.4, 1.4.5] (conflict analysis result)
- Conclusion: don't install allure-framework/allure-php-api[1.2.1] | install one of allure-framework/allure-php-api[1.1.0, ..., 1.1.8] (conflict analysis result)

To my knowledge, I haven’t changed anything. Last upgrade went fine (from 2.4.2 to 2.4.2-p1).
This is my composer.json file content:

"require": {
    "fooman/pdfcustomiser-m2": "^8.0",
    "magento/composer-root-update-plugin": "~1.0",
    "magento/product-community-edition": "2.4.3"
},
"require-dev": {
    "allure-framework/allure-phpunit": "~1.2.0",
    "dealerdirect/phpcodesniffer-composer-installer": "^0.7.0",
    "friendsofphp/php-cs-fixer": "~2.16.0",
    "lusitanian/oauth": "~0.8.10",
    "magento/magento-coding-standard": "*",
    "magento/magento2-functional-testing-framework": "^3.0",
    "pdepend/pdepend": "~2.7.1",
    "phpcompatibility/php-compatibility": "^9.3",
    "phpmd/phpmd": "^2.8.0",
    "phpstan/phpstan": ">=0.12.3 <=0.12.23",
    "phpunit/phpunit": "^9",
    "sebastian/phpcpd": "~5.0.0",
    "squizlabs/php_codesniffer": "~3.5.4"
},

I have no idea how to continue.
Thank you,


Get this bounty!!!

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.