#StackBounty: #networking #drivers #21.04 #iwlwifi Kernel: 5.11, Wi-Fi UNCLAIMED, "dmesg |grep iwlwifi" is empty. Wifi [8086:…

Bounty: 50

What I have different from all other cases is that I have nothing on dmesg.

# dmesg |grep iwlwifi | wc -l
0
  • I have dual boot with Windows 10.
  • Windows "Fast Startup" is disabled.
  • Secure boot is disabled (I have it enabled when install the linux, but disable to fix nvidia).
  • Ubuntu 21 "Ubuntu 21.04.
  • The classic "Ubuntu Drivers" only offer drivers for NVidia
# inxi -Fxxxrz
System:    Kernel: 5.11.0-34-generic x86_64 bits: 64 compiler: gcc v: 10.2.1 Desktop: GNOME 3.38.4 tk: GTK 3.24.25 
           wm: gnome-shell dm: GDM3 3.38.2.1 Distro: Ubuntu 21.04 (Hirsute Hippo) 
Machine:   Type: Laptop System: Alienware product: Alienware x17 R1 v: 1.2.1 serial: <filter> Chassis: type: 10 
           serial: <filter> 
           Mobo: Alienware model: Alienware x17 R1 v: A00 serial: <filter> UEFI: Alienware v: 1.2.1 date: 07/12/2021 
...
Network:   Device-1: Realtek Killer E3000 2.5GbE vendor: Dell driver: r8169 v: kernel port: 3000 bus ID: 0000:3b:00.0 
           chip ID: 10ec:3000 class ID: 0200 
           IF: enp59s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz vendor: Rivet Networks driver: N/A port: 3000 bus ID: 0000:3c:00.0 
           chip ID: 8086:2725 class ID: 0280 
           IF-ID-1: docker0 state: down mac: <filter> 
...
# lspci -nnk | grep -iA3 net 
0000:3b:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. Killer E3000 2.5GbE Controller [10ec:3000] (rev 06)
    Subsystem: Dell Device [1028:0a8f]
    Kernel driver in use: r8169
    Kernel modules: r8169
0000:3c:00.0 Network controller [0280]: Intel Corporation Wi-Fi 6 AX210/AX211/AX411 160MHz [8086:2725] (rev 1a)
    Subsystem: Rivet Networks Device [1a56:1673]
# mokutil --sb-state
SecureBoot disabled
# rfkill list
0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
# sudo lshw -c network
  *-network UNCLAIMED
       description: Network controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:3c:00.0
       version: 1a
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix cap_list
       configuration: latency=0
       resources: memory:87200000-87203fff
# apt info linux-firmware | grep Version
Version: 1.197.3

In launchpad it say that device [8086:2725] Subsystem [8086:4020] was added to linux-firmware 1.187.7. But lspic say mine is [1a56:1673], that I can not find anything in internet.

Edit:

This is what windows see, it come installed on from factory.

enter image description here

Trying to enable iwlwifi, still no logs:

# lsmod | grep iwlwifi
<emtpy>

# modinfo iwlwifi | grep -i version
srcversion:     C4766991DE91166408C39CE
vermagic:       5.11.0-34-generic SMP mod_unload modversions

# modprobe iwlwifi
<empty>

# dmesg | grep -i iwl
<empty>

Edit 3

I enable panic mode and clone git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git and copy into my /lib/firmware. Everything is the same with exception of

# lsmod | grep iwlwifi
iwlwifi               380928  0
cfg80211              892928  1 iwlwifi


Get this bounty!!!

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.