#StackBounty: #linux #manjaro #npm Getting "Command not found" for global node packages

Bounty: 50

I’ve installed fkill globally by doing npm i -g fkill. I can see it installed when I do npm list. It shows only fkill as installed globally when I run npm list -g --depth=0. However when I run fkill I get “command not found”.

Next I ran “npm get prefix” and got “/home/alex/.node_modules”. Here is my PATH:

/home/alex/.node_modules/bin:/home/alex/.npm-global/bin:/home/alex/.node_modules/bin:/home/alex/.node_modules/lib/node_modules:/home/alex/.local/bin:/usr/local/bin:/usr/local/sbin:/usr/bin:/opt/cuda/bin:/var/lib/flatpak/exports/bin:/usr/lib/jvm/default/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl:/var/lib/snapd/snap/bin

This all began after I tried to run system updates with pacman and got node conflicts, so I uninstalled node and ran my updates, then reinstalled node.

Any ideas?

This is on Manjaro.


Get this bounty!!!

#StackBounty: #linux #boot #manjaro #refind Substitution of kernel version to rEFInd without autodetection

Bounty: 50

Recently I moved to a rEFInd boot loader. I changed my theme to initramfs by adding include path/to/theme.conf to the end of refind.conf. I want to disable autodetection of some kernels(or delete them via minus when loading because they are unnecessary)

This is my /boot:

efi                                intel-ucode.img      vmlinuz-5.3-x86_64
initramfs-5.3-x86_64-fallback.img  linux53-x86_64.kver  vmlinuz-5.4-x86_64
initramfs-5.3-x86_64.img           linux54-x86_64.kver  vmlinuz-5.4-x86_64.png
initramfs-5.4-x86_64-fallback.img  memtest86+
initramfs-5.4-x86_64.img           refind_linux.conf

How can I detect the version of my kernel? Without help of refind_linux.conf

I want to set the config in refind.conf, for instance:

menuentry "Manjaro" {
    icon     /EFI/refind/themes/initramfs/icons/os_manjaro.png
    volume   "SYSTEM"
    loader   "/boot/vmlinuz-VERSION_HERE"
    initrd   "/boot/initramfs-VERSION_HERE.img"
    options  "root=UUID=XXXX rw quiet apparmor=1 security=apparmor udev.log_priority=3"
    submenuentry "Boot using fallback initramfs" {
        initrd "/boot/initramfs-VERSION_HERE-fallback.img"
    }
    submenuenrty "Boot to single-user mode" {
        add_options "single"
    }
    submenuentry "Boot with minimal options" {
         options "ro root=UUID=XXXX"
    }
}

os_manjaro.png I photoshoped by myself. It works correctly.

Any extra information I can add if u ask me in comments(I don’t know what information I missed)

I heared that such stuff can be deal via postinst.d and bash/zsh script, but I didn’t find a documentation on this feature

I checked this question and this question is not a duplicate


Get this bounty!!!

#StackBounty: #linux #windows-10 #installation #uefi #manjaro I can't install Linux (+ Brick, HELP!)

Bounty: 50

I’m trying to install Linux in this computer:

  • MB: ASRock Z75 Pro3
  • CPU: I3-3220
  • GPU: AMD Radeon HD 6800
  • RAM: 8GB
  • BIOS: UEFI American Megatrends ICN 2.00, 2013/10/9
  • SMBIOS version: 2.7.
  • SSD with two HDD in RAID as a slave
  • Windows 10

I’ve done the next actions:

  • I disabled SecureBoot
  • I disabled Fastboot
  • I have checked the ISO of Manjaro
  • I made the bootable USB again (Rufus and Etcher) with 3 different USB sticks.
  • I started with restart+shift (win) and selecting the UEFI USB Manjaro installation (and also the Legacy before)
  • I tried with Puppy Linux also and get similar results (when it is loading kernels in the installation process I get a black screen)
  • I tried with Puppy in DD mode (Rufus)
  • I checked that the disk is in a GPT mode
  • I tried with Arcolinux broking the PC (more info below)

All that I get is the Manjaro installation menu, I select languages and Time Zone and then select the Manjaro installation option I get a black screen. In the best results, I could see an Asrock logo for milliseconds on the screen (I think it is after a fast reboot).

Now, after trying to install Arcolinux as @vxp suggested, I have broken my computer. I get a black screen since the very beginning, I can’t see even the BIOS messages.

Any idea?


Get this bounty!!!

#StackBounty: #linux #windows-10 #installation #uefi #manjaro I can't install Linux (UEFI, SecureBoot disabled)

Bounty: 50

I’m trying to install Linux in a computer with Windows 10 and UEFI system (Asrock). Nowadays I have Win10 in an SSD with two HDD in RAID as a slave.

  • I disabled SecureBoot
  • I disabled Fastboot
  • I have checked the ISO of Manjaro
  • I made the bootable USB again (Rufus and Etcher) with 3 different USB sticks.
  • I started with restart+shift (win) and selecting the UEFI USB Manjaro installation (and also the Legacy before)
  • I tried with Puppy Linux also and get similar results (when it is loading kernels in the installation process I get a black screen)
  • I tried with Puppy in DD mode (Rufus)
  • I checked that the disk is in a GPT mode

All that I get is the Manjaro installation menu, I select languages and Time Zone and then select the Manjaro installation option I get a black screen. In the best results, I could see an Asrock logo for milliseconds in the screen.

Any idea?


Get this bounty!!!

#StackBounty: #linux #windows-10 #installation #uefi #manjaro I can't install Linux (UEFI, SecureBoot disabled)

Bounty: 50

I’m trying to install Linux in a computer with Windows 10 and UEFI system (Asrock). Nowadays I have Win10 in an SSD with two HDD in RAID as a slave.

  • I disabled SecureBoot
  • I disabled Fastboot
  • I have checked the ISO of Manjaro
  • I made the bootable USB again (Rufus and Etcher) with 3 different USB sticks.
  • I started with restart+shift (win) and selecting the UEFI USB Manjaro installation (and also the Legacy before)
  • I tried with Puppy Linux also and get similar results (when it is loading kernels in the installation process I get a black screen)
  • I tried with Puppy in DD mode (Rufus)
  • I checked that the disk is in a GPT mode

All that I get is the Manjaro installation menu, I select languages and Time Zone and then select the Manjaro installation option I get a black screen. In the best results, I could see an Asrock logo for milliseconds in the screen.

Any idea?


Get this bounty!!!

#StackBounty: #linux #windows-10 #installation #uefi #manjaro I can't install Linux (UEFI, SecureBoot disabled)

Bounty: 50

I’m trying to install Linux in a computer with Windows 10 and UEFI system (Asrock). Nowadays I have Win10 in an SSD with two HDD in RAID as a slave.

  • I disabled SecureBoot
  • I disabled Fastboot
  • I have checked the ISO of Manjaro
  • I made the bootable USB again (Rufus and Etcher) with 3 different USB sticks.
  • I started with restart+shift (win) and selecting the UEFI USB Manjaro installation (and also the Legacy before)
  • I tried with Puppy Linux also and get similar results (when it is loading kernels in the installation process I get a black screen)
  • I tried with Puppy in DD mode (Rufus)
  • I checked that the disk is in a GPT mode

All that I get is the Manjaro installation menu, I select languages and Time Zone and then select the Manjaro installation option I get a black screen. In the best results, I could see an Asrock logo for milliseconds in the screen.

Any idea?


Get this bounty!!!

#StackBounty: #linux #windows-10 #installation #uefi #manjaro I can't install Linux (UEFI, SecureBoot disabled)

Bounty: 50

I’m trying to install Linux in a computer with Windows 10 and UEFI system (Asrock). Nowadays I have Win10 in an SSD with two HDD in RAID as a slave.

  • I disabled SecureBoot
  • I disabled Fastboot
  • I have checked the ISO of Manjaro
  • I made the bootable USB again (Rufus and Etcher)
  • I started with restart+shift (win) and selecting the UEFI USB Manjaro installation (and also the Legacy before)
  • I tried with Puppy Linux also and get similar results (when it is loading kernels in the installation process I get a black screen)
  • I tried with Puppy in DD mode (Rufus)
  • I checked that the disk is in a GPT mode

All that I get is the Manjaro installation menu, I select languages and Time Zone and then select the Manjaro installation option I get a black screen. In the best results, I could see an Asrock logo for milliseconds in the screen.

Any idea?


Get this bounty!!!

#StackBounty: #linux #windows-10 #installation #uefi #manjaro I can't install Linux (UEFI, SecureBoot disabled)

Bounty: 50

I’m trying to install Linux in a computer with Windows 10 and UEFI system (Asrock). Nowadays I have Win10 in an SSD with two HDD in RAID as a slave.

  • I disabled SecureBoot
  • I disabled Fastboot
  • I have checked the ISO of Manjaro
  • I made the bootable USB again (Rufus and Etcher)
  • I started with restart+shift (win) and selecting the UEFI USB Manjaro installation (and also the Legacy before)
  • I tried with Puppy Linux also and get similar results (when it is loading kernels in the installation process I get a black screen)
  • I tried with Puppy in DD mode (Rufus)
  • I checked that the disk is in a GPT mode

All that I get is the Manjaro installation menu, I select languages and Time Zone and then select the Manjaro installation option I get a black screen. In the best results, I could see an Asrock logo for milliseconds in the screen.

Any idea?


Get this bounty!!!

#StackBounty: #linux #windows-10 #installation #uefi #manjaro I can't install Linux (UEFI, SecureBoot disabled)

Bounty: 50

I’m trying to install Linux in a computer with Windows 10 and UEFI system (Asrock). Nowadays I have Win10 in an SSD with two HDD in RAID as a slave.

  • I disabled SecureBoot
  • I disabled Fastboot
  • I have checked the ISO of Manjaro
  • I made the bootable USB again (Rufus and Etcher)
  • I started with restart+shift (win) and selecting the UEFI USB Manjaro installation (and also the Legacy before)
  • I tried with Puppy Linux also and get similar results (when it is loading kernels in the installation process I get a black screen)
  • I tried with Puppy in DD mode (Rufus)
  • I checked that the disk is in a GPT mode

All that I get is the Manjaro installation menu, I select languages and Time Zone and then select the Manjaro installation option I get a black screen. In the best results, I could see an Asrock logo for milliseconds in the screen.

Any idea?


Get this bounty!!!

#StackBounty: #linux #windows-10 #installation #uefi #manjaro I can't install Linux (UEFI, SecureBoot disabled)

Bounty: 50

I’m trying to install Linux in a computer with Windows 10 and UEFI system (Asrock). Nowadays I have Win10 in an SSD with two HDD in RAID as a slave.

  • I disabled SecureBoot
  • I disabled Fastboot
  • I have checked the ISO of Manjaro
  • I made the bootable USB again (Rufus and Etcher)
  • I started with restart+shift (win) and selecting the UEFI USB Manjaro installation (and also the Legacy before)
  • I tried with Puppy Linux also and get similar results (when it is loading kernels in the installation process I get a black screen)
  • I tried with Puppy in DD mode (Rufus)
  • I checked that the disk is in a GPT mode

All that I get is the Manjaro installation menu, I select languages and Time Zone and then select the Manjaro installation option I get a black screen. In the best results, I could see an Asrock logo for milliseconds in the screen.

Any idea?


Get this bounty!!!