#StackBounty: #magento2 #layout #template #overrides #upgrade Can't override template from own module

Bounty: 50

It seems to be impossible to override the template vendormagentomodule-checkoutviewfrontendtemplatescartitemrendereractionsedit.phtml from your own module e.g. by using layout updates.

(The template shows the edit button near quote items in the cart)

Preconditions:

Magento 2.3.5-p2

Steps to reproduce:

  1. Create own module (In my case: Company_Configurator)
  2. Create Template file: appcodeCompanyConfiguratorviewfrontendtemplatescartitemrendereractionsedit.phtml and change content.
  3. Create layout update file appcodeCompanyConfiguratorviewfrontendlayoutcheckout_cart_item_renderers.xml with following content:
<?xml version="1.0"?>
<!--
/**
 * Copyright © Magento, Inc. All rights reserved.
 * See COPYING.txt for license details.
 */
-->
<page xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:framework:View/Layout/etc/page_configuration.xsd">
    <body>
        <referenceBlock name="checkout.cart.item.renderers.simple.actions.edit">
            <arguments>
                <argument name="template" xsi:type="string">Company_Configurator::cart/item/renderer/actions/edit.phtml</argument>
            </arguments>
        </referenceBlock>
    </body>
</page>

Attempt 2:

I even tried to extend the block class, override it with dependency injection and then set the template:

app/code/Company/Configurator/etc/frontend/di.xml:

<?xml version="1.0"?>
<config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:framework:ObjectManager/etc/config.xsd">
    <preference for="MagentoCheckoutBlockCartItemRendererActionsEdit"
                type="CompanyConfiguratorBlockCartItemRendererActionsEdit" />
</config>

appcodeCompanyConfiguratorBlockCartItemRendererActionsEdit.php

namespace CompanyConfiguratorBlockCartItemRendererActions;

class Edit extends MagentoCheckoutBlockCartItemRendererActionsEdit
{
    protected $_template = 'Company_Configurator::cart/item/renderer/actions/edit.phtml';

    function __construct(MagentoFrameworkViewElementTemplateContext $context, array $data = [])
    {
        parent::__construct($context, $data);
    }

    ...

}

Expected result:

Template should get changed to own template.

Actual result:

Old template is still loading.

Please Help


Get this bounty!!!

#StackBounty: #apt #upgrade #20.04 #19.10 #proxy Why am I getting "Authentication failed" while running do-release-upgrade fr…

Bounty: 50

I’m running squid-deb-proxy server in my local network. It works well for all package downloads while running all APT commands. It is configured for all possible known URLs of the mirrors including old-releases. The Ubuntu 19.10 client has installed client side – the squid-deb-proxy-client package.

$ dpkg -l squid-deb-proxy-client | tail -n1
ii  squid-deb-proxy-client 0.8.14+nmu2  all          automatic proxy discovery for APT based on Avahi

$ sudo apt update 
Hit:1 http://archive.ubuntu.com/ubuntu eoan InRelease
Hit:2 http://archive.ubuntu.com/ubuntu eoan-updates InRelease
Hit:3 http://archive.ubuntu.com/ubuntu eoan-backports InRelease
Hit:4 http://security.ubuntu.com/ubuntu eoan-security InRelease
Reading package lists... Done
Building dependency tree       
Reading state information... Done
All packages are up to date.

But when I try to start upgrade process to get 20.04 LTS – using sudo do-release-upgrade in the terminal I got the following error message:

$ sudo do-release-upgrade 
Checking for a new Ubuntu release
Your Ubuntu release is not supported anymore.
For upgrade information, please visit:
http://www.ubuntu.com/releaseendoflife

Get:1 Upgrade tool signature [1 554 B]                                                                                                              
Get:2 Upgrade tool [1 342 kB]                                                                                                                       
Fetched 1 343 kB in 0s (0 B/s)                                                                                                                      
authenticate 'focal.tar.gz' against 'focal.tar.gz.gpg' 
Authentication failed
Authenticating the upgrade failed. There may be a problem with the network or with the server. 

I do not see anything special in the logs on squid-deb-proxy server side:

==> /var/log/squid-deb-proxy/access.log <==
1595069772.862    212 192.168.3.47 TCP_MISS/200 3349 CONNECT changelogs.ubuntu.com:443 - HIER_DIRECT/91.189.95.15 -
1595069774.726      2 192.168.3.47 TCP_MEM_HIT/200 1950 GET http://archive.ubuntu.com/ubuntu/dists/focal-updates/main/dist-upgrader-all/current/focal.tar.gz.gpg - HIER_NONE/- application/x-gzip
1595069775.410    681 192.168.3.47 TCP_HIT/200 1342082 GET http://archive.ubuntu.com/ubuntu/dists/focal-updates/main/dist-upgrader-all/current/focal.tar.gz - HIER_NONE/- application/x-gzip

How should I fix the problem with Authentication failed to run the upgrade through proxy server normally? I do not want to switch proxy server (or exclude its configuration from the client) off to fix the problem.


Notes:

  1. For possible close-voters: the same happening when I try to upgrade 18.04 LTS to 20.04 LTS with sudo do-release-upgrade -d.
  2. I have reported bug 1888058 to launchpad.


Get this bounty!!!

#StackBounty: #linux-mint #upgrade Delete foreign packages in Migration to Linux Mint 20

Bounty: 50

The new version of Linux Mint 20 has been announced and along with it a tutorial to help us in the migration process.

I followed the steps described there until D2. Check the upgrade where I executed mintupgrade check and the output seems fine to me.

Now, when I check all of the other steps (before starting the actual upgrade), I see there is a step D6. Delete foreign packages which says:

With the exception of packages you installed yourself (from 3rd party sources), select all foreign packages and click "Remove".

When I check all of the foreign packages installed (from "Menu -> Administration -> Software Sources -> Maintenance -> Remove Foreign Packages") I see there are a LOT of them.

I’m able to recognize some of these packages, but I’m not sure about most of them.

So,

What are the implications of not doing this step?

Related, What if I remove accidentally a package that is needed by some app later on? Can I recover it? (I guess so, but I’m not sure if it is safe to do so)

What may be the best way to approach this step?


PS: I’m an intermediate experienced Linux user.


Get this bounty!!!

#StackBounty: #upgrade #python #sudo #pip Are two instances of pip & youtube-dl installed after using sudo to update?

Bounty: 50

I always used pip3 install --upgrade pip && pip3 install --upgrade youtube-dl to update pip and the relevant program youtube-dl. However, I started getting the warning:
Defaulting to user installation because normal site-packages is not writeable
Requirement already up-to-date:...

First, I tried only typing pip instead of instances of pip3 and subsequently only pip, but those attempts resulted in ‘real’ errors.
Then I went for sudo pip3 install --upgrade pip && sudo pip3 install --upgrade youtube-dl.
Both programmes were downloaded and installed, but the version of youtube-dl that was replaced was so old that I’m sure it’s not the only which I regularly updated using the command mentioned in the first line.
Now, I suspect I have installed two instances of each of those programmes, one root and one not. Is that true? If so, how do I get rid of one – preferably the root one since sudo privileges are not necessary, I believe.

And off topic: What causes the original warning and how do I fix it instead?


Get this bounty!!!

#StackBounty: #ubuntu #upgrade #dependencies Ubuntu 16.04 apt upgrade leads to circular dependency

Bounty: 100

# apt upgrade
The following packages have unmet dependencies:
 linux-headers-generic : Depends: linux-headers-4.4.0-177-generic but it is not installed
 linux-image-4.4.0-177-generic : Depends: linux-modules-4.4.0-177-generic but it is not installed

Trying to install linux-modules-4.4.0-177-generic

# apt install linux-modules-4.4.0-177-generic
...
The following packages have unmet dependencies:
 linux-headers-generic : Depends: linux-headers-4.4.0-177-generic but it is not going to be installed

So, headers-generic requires headers-4.4.0-177-generic which requires modules-4.4.0-177-generic which require headers-4.4.0-177-generic

Question is how to resolve this circular dependency?

System always suggests to

You might want to run ‘apt-get -f install’ to correct these.

But I’m not sure if -f is best solution.


Get this bounty!!!

#StackBounty: #ubuntu #ansible #upgrade #dpkg How to force ansible apt upgrade to install new configuration files (force-confnew)

Bounty: 50

I have an Ubuntu 18 LTS host which I want to upgrade via ansible and force apt-get dist-upgrade to install any new configurations available overwriting any existing ones, as if I was there pressing the first option of that dialog:
apt-get dist-upgrade dialog

I’m looking into the ansible apt_module documentation and cannot get this to work. In all cases my touched configurations are maintained, and the new vendor ones are stored in .ucf-dist files.

So far I’ve tried:

# 1:
ansible -i my-hosts foo -m apt -a 'update_cache=yes upgrade=safe dpkg_options=force-confnew'

# 2:
ansible -i my-hosts foo -m apt -a 'force_apt_get=yes update_cache=yes upgrade=safe dpkg_options=force-confnew'

# 3:
ansible -i my-hosts foo -m apt -a 'force_apt_get=yes update_cache=yes upgrade=dist dpkg_options=force-confnew'

FYI I reproduce this locally with VirtualBox snapshots where I revert after every test.


Get this bounty!!!

#StackBounty: #debian #upgrade #headless Was on Debian stable – How did I end up on Bullseye?

Bounty: 50

May be a silly question, but a remote server was down for an extended period today – when it came back up I realized the downtime was apparently due to a system upgrade, from Debian Buster (stable) to Bullseye (testing).

I’m a bit confused because I am the only superuser on this server, and I have not scheduled any kind of update in some time. I don’t run production machines on testing, and I didn’t intentionally set the system up to automatically upgrade operating system versions. I do periodically use apt to update and upgrade individual packages, but I certainly did not call for a full release upgrade.

Any obvious configuration settings I might have made to trigger this – for example, changing my apt sources unintentionally or etc.? I don’t want any more unexpected updates. (It’s a headless Minecraft server, for what it’s worth, and downtime is bad when people want to play.)


Get this bounty!!!

#StackBounty: #sharepoint-server #2016 #upgrade #access-denied #2019 Access denied after upgrade from SP 2016 to SP 2019

Bounty: 50

I’ve been preparing an upgrade from SharePoint 2013 to 2019. So far I’ve managed to attach the database to 2016 and successfully upgraded it.

I was able to use the site collection without any problems. So I dismounted the database from 2016 and mounted it to 2019. Upgrade steps where successfully executed and I even ran psconfig (Gui) just to be sure.

My problem is that I get an access denied message when I try to open the site with farm/site collection administrator. Removing the site collection administrator and adding him again didn’t help.

http://hostname/_layouts/15/AccessDenied.aspx?Source=http%3A%2F%2Fhostname&correlation=c24e2c9f%2D6a56%2De0b3%2D1e0f%2D6703bab98e37&Type=list&name=%7BCC5EEC1C%2D42B9%2D4933%2D9B7C%2DBF8FE30E40C7%7D

The access denied url contains a list guid which (using Powershell which works just fine) I traced back to the master page gallery. It seems I lost access to my master page gallery, which doesn’t make a lot of sense to me. Can anyone help?

Update: Not sure if it’s relevant, but it’s a host named site collection.


Get this bounty!!!

#StackBounty: #upgrade #ssd #hardware Ubuntu migrate from HDD to SSD

Bounty: 100

My old HP becomes quite rusty so I want to add an SSD alongside the HDD, but I don’t won’t to lose all my data.

I would like to transfer all the application and root folders to the SSD so the OS will boot from it. However, the /home directory should remain on the HDD because is to large for the SSD.

I’m not a newbie in Linux, but I certainly don’t have enough experience to accomplish the task.

So I would like if someone could make a detailed guide on how to do it. The workflow should roughly be something as follow:

  1. Create a back up so I can always revert all the changes
  2. Migrate from the SSD to the HDD (selecting a file system, linking the home dir, BIOS settings etc.)
  3. Updating from Ubuntu 18.04 to the latest version


Get this bounty!!!